Problem
The site gateway or camera has a zero config or APIPA IP address. This is an IP address in the 169.254.0.0/16 range.
Cause
An IP address in this IP range is used by a network device that is configured for DHCP but communication to the DHCP server has failed and so it is unable to get an IP lease from the DHCP server.
Solution
If there is a DHCP sever on the network, investigate the following on the customer network:
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Traffic is blocked from getting to the DHCP server
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The server has no spare lease in the DHCP scope
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The DHCP server is incorrectly configured
If there isn't a DHCP server on the network:
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Set the gateway and camera to a static IP on the local subnet. For more information, see Configure a Site Gateway to Connect to the Network Using a Static IP Address
Note
You can also use this as a work around for a DHCP issue but make sure you are not applying a static IP that it is not within the DHCP scope or already in use.
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To set a camera to a static IP, connect to the site gateway via SSH to load the camera web interface, and load the camera web interface using the 169.254.0.0/16 address it is using. You can then configure a static IP in the UI.
Problem
Cameras are offline in the gateway because they have renewed their DHCP lease and got a different IP address.
Cause
Cameras configured to use DHCP will periodically renew their IP address with the DHCP server. Their new DHCP leased IP address will not always be the same as their old leased IP address. When this happens, the site gateway does not always recognize this change and fails to update the camera IP information in the dashboard. This leads to the camera being offline as the gateway is attempting to connect to the camera using the old leased IP address.
Solution
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Run a camera discovery in the gateway (link to camera discovery doc)
The results from the camera discovery scan will show the “new” cameras that the gateway can now see on the network. These will be the same cameras but with their newly leased IP addresses.
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Update the camera IP addresses in the camera settings in the gateway
In case of multiple cameras, you might be able to use the camera serial numbers available on the dashboard to determine which IP address belongs to which camera.
Note
If the gateway is at full capacity and you are not a superuser, please contact sites-support@samsara.com.
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